Announcement

Collapse
No announcement yet.

Thermostat replacement on a V6 Camaro

Collapse

Unconfigured Ad Widget

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thermostat replacement on a V6 Camaro

    What a PAIN IN THE ASS!!! who's idea was to put the thermostat in the back of the engine??!! After 2 days I got the tstat housing installed. this is difficult in the driveway with about 2-3 inches of arm room. Now for some reason it is leaking, so another few days to determine what's wrong. I was sure everything is buttoned up properly. probably easier on a lift. access is impossible from the top. it would be easier to drop the front exhaust for better access, no wonder chevy charges so much for R&R.
    2016 Camaro RS, White. No Mods.....so far........:)

  • #2
    Finally done.
    2016 Camaro RS, White. No Mods.....so far........:)

    Comment


    • #3
      A little late seeing this. Was the little tab on the gasket for the thermostat out of place?
      Sometimes we forget

      Comment


      • #4
        Yep. I learned that the hard way. Of course, it fell out when I removed the hoses so I had no frame of reference.
        2016 Camaro RS, White. No Mods.....so far........:)

        Comment


        • #5
          Yikes... what a PITA

          Comment


          • #6
            then I learned that the cap is bad, spews coolant (I was smelling a coolant smell inside the car and investigated when I got home, coolant was dribbling out of the filler neck at some point) when the temps get to 215-221 before fans kick in. traffic has been really bad lately....So it got replaced last night. installed a Vitesse throttle controller a few days ago, recycled the battery and the engine runs like it never has since I have had it...YAY!
            2016 Camaro RS, White. No Mods.....so far........:)

            Comment


            • #7
              Ok, Moving on. the car runs really good. took it in for it's state inspection. The computer points out that several components are not ready. WTF??!! So it fails inspection....
              Evidently, I needed to drive the car a few more miles before I had it checked. So I drove it about a 100 miles and then took it back in the next day. Only one of those 4 components are set to ready. the other three still do not. Now I tried to see this but my reader does not have the feature to check the components. So I went to O'reillys, apparently their reader doesn't either...ugh!!
              Lo and behold on the way home, the CEL goes off again, flashing this time....P0300, this seems to be consistent and cannot figure out what's wrong. I tried to take it in to chevy, any dealer, over a week sitting until they can get to it. UM no....getting sick of this car.....
              2016 Camaro RS, White. No Mods.....so far........:)

              Comment


              • #8
                sorry to hear of your trouble.....you have way more on your plate than to have to deal with this kind of crap too.

                Comment


                • #9
                  Exactly.
                  I called the dealer that worked on the car last year before I bought it. They said it produced an error code in the ECM for worn timing chains so they replaced them (weird worn chains at 70k miles???). I couldn't get an answer for the reason the crankshaft was replaced. That's a serious issue. they asked me to bring it in so they can look at it....uh no....! However, Im thinking that this pertains to why the idle is erratic at time and why the light goes off at around 3500 rpms. what concerns me is that why they didn't find bad coils, and plugs. and the maf sensor was also not operating correctly. all of which I corrected. It seemed to have smoothed the idle and the driveability issues. See my post about after I bought the car, it goes over all that. Now Im thinking the remaining issue still revolves around those cams somehow. Maybe the cam sensors (well one of them)? The crank sensor as well. Shouldn't they have replaced those when they replace a crank and timing chains? Now going on 2 months out of inspection, I cannot seem to get the I/M parameters to reset. Im down to 2 monitors from 4 when it failed inspection. But the car runs great!! I don't get it...
                  2016 Camaro RS, White. No Mods.....so far........:)

                  Comment


                  • #10
                    Ok, she finally passed on Saturday. Yay.
                    2016 Camaro RS, White. No Mods.....so far........:)

                    Comment


                    • #11
                      great news!

                      Comment

                      Working...
                      X